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1. Dejinition o Compuier System

A Cemputer System is a cembinalien e} hardware and
sellware cempenents thal werk legelher lo perjerm

dala precessing tashks. 1 lakes inpul., precesses il,

sleres il, and preduces cutpul.

T 2. Block Diagram o} Computer
Sysiem

mCapq code

! MImpwt |—] CPU [—>] Output |/
/| Devices [ JCU+ALU+ | | Devices /[
/ [ [ Registers) [ /[ /

/[ Memery |/
[ (RAM & ROM) /




&* 3. Campeonents o} Compuier System
A. Hardware

Physical parls ¢} a compuler system.

I. Central Processing Unit (CPU)

¢ Coniral Unit (CU). Directs eperalicns.

® Arithmeiiec Logic Unit (ALU). Pertorms calculalions

and legic eperaliens.

® Reglsters. Small slerage unils inside CPU per paslt

dala access.

il. Memery

® Primary Memoery.

0 RAM (Random Access Memery). Temperary,

velalile.

o ROM (Read Only Memoary). Permanent,

naen—velalile.



® Secondary Memory.

o HOD (Hard Disk Drive). Magnelic. large

capacily.

o 88D (Sclid State Drive). Tasler. ne meving parls.

iitl. Input Devices

Used Lo enler dala.

* Reybeard
e Mouse
® Scanner

¢ Microphene

iv. Output Devices

Used Lle shew resulls.

* Monitor (Display Unit).
o CRT
o LCV/LED

* Printers

® Speakers



v. Peripheral Devices
Addilienal devices cennecled le enhance punclicnalily.

e Exlernal drives
® Webcams
® Joyslicks

® USB devices

H 4. Sejtware

Pregrams thal run en hardware and perjerm specijic

lashs.
A. Types o} Sojtware

i. System Sojtware

®* Manages and centrels hardware.

o Examples. Operaling Sysiem. Device Drivers.



il. Applicatien Sejtware

® User-eriented sajlware.

¢ Cxamples! MS Werd, Excel, VEC Media Player.

ith. Utility Septware

® Mainlains and eplimizes syslem perjermance.

o Examples. Anlivirus, Disk Cleanup. Bachup leels.

B 5. Overview o) Operaling System (08)

A. What is an 982

An Operaling System is a sysiem seplware thal acls as
an inlerjace belween user and hardware. 1l manages

resources and cenlrels execulien e} pregrams.

8. Tunciions o} 98

1. Process Management
2. Memeory Management

3. File System Managemenl



4. Device Managemenl
0. User Inlerpace

6. Security & Access Canlrel

6. Brie} History en Evelution of DS

1. 1950s. Ne 08, pregrams executed manually.
2. 1960s. Balch Precessing Syslems.
3. 1970s. Time Sharing & Mulli-user 03.

Y, 1980s: Persenal Cempulers & GUI-based 0S8.

5. 1990s — Present. Mullitasking, real-lime, meobile &
cloud 08.



@2 7. Types o} Dperating Systems

Type Description
Baich 98 Execules balches o} jebs wilheul
inleraclion

Muliiprogramming ‘Mulliple pregrams in memary

simullanecusly

Mulititashing Run several lashs al ence Lor

single user

Real-Time 08 Respends te inpul instantly,

used in crilical systems

Time-Sharing CPU time is divided ameng

users, suppoerts mulliple users



8. Operating System Structures

Manclithic Kernel — All 08 services in ene large

blechk (e.qg. Unix).

. Microkernel — Only essenlial services in hernel,

resl in user space (e.qg. QNX).

. Layered Structure — 08 is divided inle layers por

medularily (e.g. THE 08).

. Modular 98 — Ceore hernel wilh dynamically

lcadable medules (e.g. Linux).

. Client-Server Madel — 98 services lrealed as

iepara le server precesses.
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1. Number Systems

A Number System is a way lo represent numbers using
a base (radix). The cemmenly used number syslems in

digilal eleclrenics and cempuling are.

A. Decimal Number System (Base-10)

®* Digils. 0—9
® Mosl cemmenly used by humans

® Lach digils pesilien represenls a pewer o} 10

Example: 254 = 2%10% + 5%107 + 4X10°

8. Binary Number Sysiem (Base-2)

® Digils. 0 and 1
® Used in digilal campulers

® ach digil (bil) represenls a power o} 2

Example. 1011 = 1X23 + 0X22 + 127 + 1x2° = 11
(Decimal)



C. Octal Number System (Base-8)

® Digils. 0—7

® Sherl representalion o} binary (each eclal digil = 3

binary bils)

Example: 127 (Dclal) = 1X82 + 2X81 + 7x8° = 87
(Decimal)

9. Hexadecimal Number System (Base16)

®* Digits! 0—9 and A—F (A=10, B=11. .... T=15)

® Campacl represenlalioen ¢} binary (cach hex digit = 4

binary bils)

Example: 2F (Hex) = 2%X167 + 15%16° = 47 (Decimal)



@ 2. Interconversion Between Number
Systems

A. Decimal te Binary

® Divide the number by 2

® Wrile remainders in reverse

Example. 13 — Binary! 1101

8. Binary to Decimal

* Mulliply cach bil by 2" and add

Example. 1010 = 1X8 + 0X4 + 1X2 + 0X1 = 10

C. Decimal te Octal

® Divide the number by 8

® Reverse the remainders

Example. 65 — Oclal. 101



D. Octal te Decimal

®* Mulliply each digil by 8" and add

Example. 127 = 1X64 + 2X8 + 7 = 87

€. Decimal te Hexadecimal

® Divide Lhe number by 16

® Reverse lhe remainders

Example. 100 — Hex. 64

T. Hexadecimal te Decimal

® Mulliply each digil by 16" and add

Example. 2A = 2X16 + 10 = 42



G. Binary te Ocilal

® Group bils in 3 (yrom righl). cenverl each greup

Example. 101011 — 000 101 011 - 2 3 — Dclal’! 53

H. Binary te Hexadecimal

® Group bils in 4 (prem righl), cenverl each group

Example. 111101 — 0011 1101 — 3D

25| 8. Types op Codes

A. BCO (Binary Coded Decimal)

® Lach decimal digil is slered using 4 bils

® Range. 0000 (0) te 1001 (9)

Example. 59 — BCD = 0101 1001



8. Gray Cede

® Only ene bil changes belween censeculive numbers

® Reduces errer in digilal cemmunicalien
Binary te Gray Conversion Rule.

® Firsl bil remains same, resi. previous bil XOR

currenl bil

Example. Binary 1001 — Gray. 1101

C. ASC11 (American Standard Cede jor
Iniermation Interchange)

® 7-bil cede lo represent lexl

* 128 characlers (A=65, a=97, space=32)

Example. A — 1000001



9. EBCDIC (Extended Binary Coded Decimal
Interchange Code)

* 8-bil cede by 18BM
® Supperls 256 characlers

® Used in mainprames

€. Unicede

®* Universal characler sel
* Supperls all werld languages
* 8, 16, er 32-bil enceding

( (il H
* UTF8 is mest cammen



D. £€BCDIC (Extended Binary Coded Decimal
Interchange Code)

® 8-bil cede by 18BM
® Supperls 256 characlers

® Used in mainprames

€. Unicede

® Universal characler sel
® Supperls all werld languages
® 8, 16, er 32-bil enceding

® UTTF-8 is mesl cemmen

F. 18C11 (Indian Script Cede jor Injormation
Interchange)

® Developed in India

® Represenls Indian scripls (Devanagari. Bengali,

ele.)



& 1. Understanding Brewser

als”

A web brewser is an applicalion setlware used le

access and view websiles er web applicaliens.

Popular Browsers.

® Gaagle Chrome
® Mezilla Firepex
® Micreseyl £dge
® Sajari

®* Opera

Funetions o} a Browser:

* Rendering HTMY pages
* Handling cechics and cache
®* Managing labs, beockmarhs, and histery

® Secure browsing via HTTPS



) 2. Types o} Browsers

Type

Texi-based

Graphical

Mebile

Proprietary

Description

Only display lext, ne images

Shew lexl, images, videe, elc.

Optimized Lor phaenes/lablels

Made por specilic devices/

plaljerms

Exam

Lynx

Chrai

Chrei

Ama;



Q\ 3. Eplicient Use o) Search Engines

A search engline helps lecale inparmalien en the

inlernel.

Popular Search Engines.

® Goeogle
® Bing
®* DuchDuchGe

®* Yaheo

Tips por Eicient Searching.

Use queles. ‘campuler system” por exacl maleh

® Use site: la search wilthin a sile. sile wikipedia.erg

CPU
® Use - Lo exclude lermys. apple -ruil

® Use pilelype: la Lind piles. neoles jilelype!pd)



& 4. 1P Address

An 1P Address (Internet Prolocel Address) is a unique

number assigned le each device en a nelwerh.

Types.

* 1Pv4: e.q.. 192.168.0.1 (32-bit)

® 1Pv6. c.g.. 2001.0db8.:85a3::8a2¢.0370.:7334 (128-bil)



€ 5. HTT? and HTTPS

* HTTP (HyperTexi Transjer Prolocel):
Prolocel used le lransjer dala belween web servers

and brawsers.

o HTTPS (HTT?P Secure):
Secure versien op HTTP thal enerypls dala using
SSE/TELS.

Key Dijjerence.
HTTP is nel secure, while HTTPS is encrypled and

secure (padleck icon).

6. Cockies

® Coskles are small piles slered en your brewser by

websiles.
® They help in!
O Remembering login delails
0 Persvenalizing user experience

0 Tracking user aclivily (or ads, analylics)



% 7. How to Delete Browser Dala
Steps (Example. Google Chreme).

1. Open Chrame
2. Go lo Menu > Hislory > Clear browsing data
3. Chease!

© Browsing hislery

© Ceahics and ather sile dala

© Cached images and jiles

Y4, Click Clear data

Shoricut. Cirl + Shijt + Delele

é 8. Downleoads

® Files yrem the inlerncl can be downleaded using

brewscrs.

®* Downlead managers can speed up and erganize

downloads.

® Downleads jelder is usnally the dejaull slerage

loarnsallan



VE< 9. Emails

®* A methed lo send digilal messages ever Lhe

inlernel.
®* Requires an email address (e.g..

yeurname@qgmail.com)

Commean Email Services.

® Gmail
® Dullach

®* Yaheo Mail

Rey Features.

® Inbex. Senl, Drajls, Spam
®* Allachmenls

® fabels and jpillers



= 10. Awareness about Digital India
Pertals

A.

Natienal Portals

www.lndia.gov.ln — Nalienal Perlal o} India

www.dlgilocker.gov.ln — Fer slering ejlicial

documents
www.bharal.gev.in — Digilal India plaljerm

www.ekalavyaindia.com — Digilal learning

reseurces

State Portals (Example. West Bengal)

wb.gev.in — Wesl Bengal Gavl Porlal
banglarbhumi.gev.in — Land Recerds

wbreglsiration.gov.in — Preperly regisiralien



;? 11. Ceollege Pertals

® Used per sludent legin, pee paymenlts, resulls,

nelices, elc.
® Tnclude L'MS (Learning Managemenlt Systems)
® Example Lealures.
O Online Allendance

© Exam Registration

O Digilal Nelice Beard



0 HTML (HyperText Markup
Language)

® Initreduction

HTML is the standard markup language used le creale
web pages. 1l siruclures cenlenl using tags and

elements.

* HTMYL Tags

® Tags are used leo dejine elemenls.
¢ Examples. <himl> <head> <bedy> <p> <a> elec.

® Tags usually ceme in pairs. <lagname>conlenl</

lagname~>

* HTML Elements

® An HTMYL elemenl includes the starl lag, cenlent,

and cend lag.

® Example. <p>This is a paragraph.</p>



* HTML Text & Formatiing

* Beld.! <b> or <sireng->
® ftalic. <i> or <em>
* Underline. <u~

®* Prejormatied text. <pre-

* HTML Atiributes

®* Provide addilienal injermalion aboul elemenis.

® Example! <img srce="image.jpg’ all="Descriplion’

* HTML Fonts (Deprecated in HTMLS)

® Old melhed. <pent size="3" celer="red>Texl</jenl>

® Moedern way. Use CSS



* HTML Lists

® Ordered list. <cl><li>Tlem</li></el>
® Unerdered list. <ul><li>Tlem</li></ul>

* Dejinition list. <di><dl>Term</dl><dd>Dejinilien</dd></dl>

¢ HTML Images

® <img src="url’ all="descriplion™

* HTML Links

® Text links. <a hrep="hilps.//example.cam™Visil</a>

®* Image links. <a hrep="url><img src="image.jpg™></a>

* HTML Commenis

® Synlax. <!-—— This is a comment —>



* HTML Tables

Himl [°) Copy cede

<lable>
<lr><th>Header</th></lr>
<ir><td>Dala</td></1r>

</lable>

¢ Celoers and Bachground

o Text celer: siyle="celorred
® Bachground celer: siyle="background-celeriyellow

® HTML Ceolor Codes. e.g., #FF5733, rgb(255,0.0)

* Web Ferms

®* Faorm tag. <torm aclion="method="">
® Texi pield. <inpul lype="lexl">

® Password. <inpul lype="passwerd™>



* Hidden pleld. <inpul lype="hidden'>

Checkbex. <inpul lype="chechbox’

Radie. <inpul lype="radic"™

Submit. <inpul lype="submil™

Resel. <inpul lype="resel’

Textarea. <ilexlarca></lexlarea>

Select/Drepdewn:

Himl Ez]‘:“f“f code

<selecl>
<aplien value="1>One</aplion>

</selecl>

* File Uplead. <inpul type="jile’>

¢ Special Tags

® <body>. Detines the bedy o} the decument
® <meta>. Provides meladala (e.q.. charsel, viewpert)

® <giyle>. Used por inlernal CSS



® <div>! Cenlainer por layoul and slyling

® <jrameset>. Used Ler crealing prames (absalele in

HTMLS)

¢ Fermatting Tags Summary

® Beold. <b>, <sireng>
* Paragraphs. <p-
® Headings. <ni1> lo <h6>

o Line Break. <br>

&) €88 (Cascading Style Sheels)

¢ CS8S Intreduction

CSS is used te style and layoul HTML elemenlts (celers,

Lenls. pesilicning. elc.)



¢ CS8S Syniax

Cue

seleclar {
properly. value,

/

2 .
xample.

Cus

p{

calaer. blue,

}

|j Copy code



® (CSS Selectors

e flement Selector: p
¢ 1D Selectar. #idname

e Class Selector:. .classname

¢ C8S8 Types

1- qnll'ne! css: 5*"110:"0010!‘.' red. L
2. Internal C8S. Wilhin <siyle> lag in <hcad->

3. External C88. Linhked via <link rel="slylesheel’

hrep="slyle.css™>

¢ Siyling with CSS

® colaor, lexl-align, lexl-deceoralion, lexl-lransterm



® jenl-pamily, Lenl-size, jenl-weighl

® gllink, a.visiled, a'hever, a.aclive

® baerder, padding, lexl-align, berder-cellapse

4| Border & Margin

® berder: 1px selid blach.

® margin. 10px.;



Display

® display. block [ inline /inline-bleck / nane

® lexl-align, verlical-align, margin. aule



OpenOtice Writer (Word Processer)

1. Page Selup

® Tound under Formal > Page.

®* Cuslemize page size. erienlalien (Porirait/

fandscape). margins, berders.

2. Tables

® Insert via Table > Insert > Table er leclbar.

® Sel number o} rews & celumns.

® fealures include. merge cells, adjust celumn width,

apply berder slyles.
3. Insertion o} Pictures

®* Use Insert > Piclure > Frem File.
® Resize, crap, wrap lext areund images.

® Piclure leclbar gives alignmendl, lransparency. and

Lillers.



4. Page Layout
® Includes margins, celumns, headers/peclers. and
seclions.

®* Tound in Formal > Page.

9. Bullets and Numbering

® Access prem teclbar er Fermal > Bullels and

Numbering.

® Cusleamize bullel symbels, slyles, indenlalion.

6. Insertion o} Objects and Symbeals

® Use Insert > Object por charls, OLE ebjecls (like

spreadsheels).

® Use Insert > Special Characler por symbels like ©, T,

ele.

7. Header. Tecter. Page Number

® fnable via Mnsert > Header/Focler > Depaunll.
® Page Numbers. Inserl > Fields > Page Number.

¢ Usepul er repert and beek Lermalting.



Q OpenOilice Cale (Spreadsheet)

1. Foermat Cell Properties

® Righl-click a cell —» TFormal Cells.
® Change.
© Number ermal (Currency, Dale, Percent)
O Fanl & Lonl eplecls
© Bachground celer
O Berder slyle

© Alignmenl (herizental/verlical)
2. fermula

¢ All permulas slarl wilh =
® Examples.

0 =SUM(A1:A10)

O =AVERAGE(B2:8B5)

O =1F(A1-10, “Yes', “No")

® Use Funclion Wizard (Insert > Funclien) le jind and

inserl permulas.



3. Sart and Filiers

® Sarl! Dala > Serl. Serl by celumn (ascending/

descending).
°* Filter:
O AuleFiller: Dala > Filler > AuleFiller
O Slandard Filler: Cuslem cendilians per illering

dala.

4, Charts

® Inserl via Insert > Charl.
® Charl iypes. Celumn, Line, Pie. Bar. Area. elec.

® Wizard allews seleclien ¢} dala range and charl

cusleamizalion.



D OpenOilice Impress (Preseniation)

1. Additien and Deletion o} Slides

¢ New Slide. Inseri > Slide or press Cirl + M.
® Delete Slide. Righl-click an slide thumbnail > Delele
Slide.
2. Design
® Cheese a slide design prom the Masler Slide er Slide
Design lab.

® Cuslemize bachgreund, layeul, jonl slyles.

3. Animatien

® Slide Shoew > Cuslem Animaliocn.
O Add ejlects te text/images.

O Animalien lypes. enlrance. exil. emphasis,

melien palhs.

O Cenlrel speed, delay. and erder ¢} animalicns.



Y, Slide Show

® Starl wilh Slide Shew > Starl prem TFirsl Slide ar F5.

e Slide Transition. Slide Shew > Slide Transilion le

animale belween slides.

® Sel duralien, seund, and aule-advance sellings.



50 What is Injermation Security?

Inpermation Security (InjeSec) rejers Lo the preoiection
o} injermaltion prem unaulherized access, disclesure,
alleralien, and destruclion. 91 ensures lthal dala

remains coenjldential, accurate, and available 1o

aulherized users.

? Why De You Need Injormation
Security?

* Te pretect sensitive data (persenal, jinancial.

business).

* To prevent cyber atiacks (e.g.. malware, phishing).

®* Te mainlain customer trust and comply with legal

regulatlons (like GDPR, HIPAA).

* Te ensure business continuily in case o} securily

breaches.

®* Te aveid jinancial lesses due le dala theyl or

coerruplien.



J,:) Basic Principles e} Injermation
Security (CIA Triad)

1. Conyidentiality

® nsuring lhal ingermalien is not accessed by

unautherized persens.

® Examples. encryplien, passwerds, access conlral.

2. Integrity

* Ensuring injermalien is accurate and unaltered.

® Cxamples. hashing, chechsums, versioen cenlrel.

3. Availability

® Ensuring injermalien is accessible when needed.

* Examples. backups, uplime menilering, redundancy.



—| Policies, Procedures, Guidelines,
Standards

Term Description

Palicy High-level rule sel (e.g..
passward pelicy)

Procedure Slep-by-slep inslruclions le

implemenl a pelicy

Guideline Recemmended praclices (nol

mandaleary)

Standard  Specijic requirements (e.q.. 189/
1€C



‘(7 Security Measures
Adminisiraiive Measures (Pecple & Process)

® Securily lraining Lor empleyees
® Risk assessmenl
® Incidenl respense planning

® Bachground chechs Lor new hires

Technical Measures (Technelogy)

® Firewalls
® Anlivirus seliware
® Cneryplion

® Intrusien Deleclion Syslems (1D8)



Q0 Pecple, Process, Techneology (PPT
Medel)

A hallstic appreach te securily.

Element Rele

Peaple Users, Admins, Securily Slayp, —

need awareness/lraining

Process Pelicies. pracedures — enjerce

rules and cempliance

Technology Toels and syslems — pirewalls,

anlivirus, encryplien



I\ Threats te Cybersecurity

1. Viruses

® Malicicus cede thal allaches le tiles/pregrams and

spreads.
2. Werms

® Selp-replicaling malware thal spreads acress

nelwerhs.

3. Phishing

®* Traudulenl emails/websiles trick users inle giving

up sensilive inje.
4. Malware

® General lerm per malicious seplware (includes

viruses, warms, ele. ).

9. Trejans

® Malware disguised as legilimale seplware.



6. Spyware

® Secrelly galhers user inpermalien wilheul censenl.

7. Adware

® Auloamalically displays unwanled ads, eplen bundled

wilh preeware.

8. Reethkils

® Tecls used le gain reel access and hide aclher

malware.

9. Email Hijacking

® Unaulherized cenlrel o} email acceunls used por

scams ar spam.



ﬁ Metheds te Preotect Your Persenal
Computers

® Install and update Antivirus sejiware
* Use Firewalls
® Regularly updale 98 and sejlware

® Aveid clicking unknewn links er dewnleading

suspicious jiles

* £nable 2-Factor Authentication (2FA)

Back up dala regularly



U What is Antivirus?

Anlivirus is seplware designed le delecl, prevent, and

remove malware and elher malicicus seplware.

O\ Types i Antivirus.

1. Signature-based. Delecls knewn malware using

virus depinilions.

2. Heuristic-based. Delecls new er unknewn malware

by behavier.
3. Cloud-based. Uses real-lime enline dalabases.
4. Real-time Antivirus. Censlanlly menilers syslem

aclivily.

Pepular Anlivirus Sejplware. Raspersky, Bildejender,
Norten, McAjee, Avasi.



@ What is a Firewall?

A pirewall is a nelwerk securily device/sejlware lhatl
menilers and cenlrels incoming and culgeing nelwark

trajlic based on predelined rules.

@ Types o} Firewalls.
* Seitware Firewall. Inslalled en individual devices
(e.qg.. Windews Firewall).

e Hardware Firewall. Physical device Lhal tillers

lraplic al the nelwaork level.

¢ Cloud-based Firewall: Hosled by securily previders

ter cloud nelwerks.



